Compatible Devices

ls my device compatible with Vector and the Vector Robot companion app?

Vector and the Vector Robot companion app are designed to work with popular modern devices.

 

Please Note: If your device cannot find and download the Vector Robot companion app in the Apple App Store, Google Play store, or Amazon Appstore, then your device will not work with Vector. Please read here for more information.

 

When selecting a mobile device to use with Digital Dream Labs products, please consider the following important guidelines:

  • Minimum requirements
  • Validated devices
  • Operating systems

 

Digital Dream Labs tests and publishes a list of devices with operating systems that we know to work well with Digital Dream Labs products. These lists are actively updated as we improve our products. Due to differences among devices, some devices that meet or exceed the minimum requirements may not work well with Vector.


Minimum Requirements

Operating System

  • iOS 10
  • Android 5 (Lollipop)
  • Fire OS 5

Hardware

  • A WiFi internet router that broadcasts in at least 802.11n 2.4GHz channels

Validated Devices and Operating Systems

 

The following are the devices and their operating systems that Digital Dream Labs is validating (using to develop and test) Vector and the Vector Robot companion app.

 

All validated devices are running at least:

  • iOS 10
  • Android 5 (Lollipop)
  • Fire OS 5.6.1.0

AMAZON KINDLE*

  •  Fire HD 8 (7th Generation)
  •  Fire HD 10 (7th Generation)
  •  Fire (7th Generation)
  •  Fire HD 8 (6th Generation)

 


APPLE

  • iPhone XS
  • iPhone XS plus
  • iPhone XR
  • iPhone X
  • iPhone 8
  • iPhone 8 plus
  • iPhone 7
  • iPhone 7 plus
  • iPhone SE
  • iPhone 6s
  • iPhone 6
  • iPhone 6 plus
  • iPhone 5s
  • iPad Pro (12.9-inch)
  • iPad Pro (10.5-inch)
  • iPad Pro (9.7-inch)
  • iPad Air 2
  • iPad Air
  • iPad (6th Generation)
  • iPad (5th Generation)
  • iPad mini 4
  • iPad mini 3
  • iPad mini 2
  • iPod Touch (6th Generation)

 


GOOGLE

  • Pixel 3
  • Pixel 3 XL
  • Pixel 2
  • Pixel 2 XL
  • Pixel C
  • Pixel
  • Pixel XL
  • Nexus 5X
  • Nexus 6P
  • Nexus 9

 


LG

  • LG G6
  • LG G5

 


MOTOROLA

  • Moto GS
  • Moto X Pure Edition

 


SAMSUNG *

  • Galaxy S9+
  • Galaxy S9
  • Galaxy S8+
  • Galaxy S8
  • Galaxy S8 Edge
  • Galaxy S7
  • Galaxy S6 Edge
  • Galaxy S6
  • Galaxy S5
  • Galaxy Note5
  • Galaxy Tab S3 (2017 Edition)
  • Galaxy Tab A 10.1 (2016 Edition)
  • Galaxy Tab A 8.0 (2016 Edition)

 

This list of validated devices may change at any time and without any notice. We will do what we can to keep this list as up to date as possible.

 

* These manufacturers have devices with the same or similar names to the devices we test and publish here, but they are not compatible with Digital Dream Labs products. For example, while we successfully test the Samsung Galaxy S5 with the Vector Robot companion app, the Samsung Galaxy S5 Neo or Samsung Galaxy 5 Mini are not tested and may not work.

 

We also have specifically disabled some devices because they have known issues with the Vector Robot companion app or are not standard. For example, the Vector Robot companion app does not support any Tablet or Device that uses an x86, x86-64, intel, AMD, or Atom based Processor. Please read here for more information.


If Vector is autonomous, why do I need to use a device with Vector? Why do I need the Vector Robot companion app?

 

While Vector is an autonomous robot (you can interact with him using your voice and he will automatically update himself when a software update is available), the Vector Robot companion app is required to:

  • Successfully set up Vector
  • Associating your Vector with your Anki Account
  • Configuring Vector to join WiFi networks and setting basic settings
  • Help you learn how to interact with Vector
  • Manage Face Recognition and Photos

Still need help? Contact Us Contact Us