"This Vector Already Has An Owner" Error Message
In some cases when connecting to Vector, an error message may appear that says:
"Can't Connect To Vector
This Vector already has an Owner. If this is your Vector, tap Get Help to learn how to reset your robot."
Important Note:
If you purchased Vector used, or received him from a family member, please Contact Us at support@digitaldreamlabs.com so that we can help you to transfer the Vector over to your own account!
Causes:
When this error occurs, there are four possible causes:
- The robot was previously owned by someone else and the previous owner did not do a Clear User Data Reset.
- The phone's authorization is no longer recognized by Vector.
- The Vector Robot app is logged into a different account than the Vector is currently registered to.
- There are mismatched credentials between Vector, the server, and the phone.
Resolutions:
This error can be solved using the following steps:
- Uninstall, reboot, and reinstall:
- Android Instructions:
- In the Settings app of the phone, find the "Apps" menu.
- Under "All Apps", find the "Vector Robot" app.
- Click the "Storage & Cache" button, then click "Clear Data".
- Click the Back Button, then click "Uninstall". Wait until the app is finished uninstalling.
- Reboot your device.
- Reinstall the app from Google Play
- Open the app, log back in (make sure you log into the account your Vector is registered to!) and retry the connection.
- iPhone Instructions:
- Long-click the Vector Robot app on the Home Screen.
- Click "Remove App", then click "Delete App"
- Restart your phone by holding the Power button, then sliding the Power slider to the right. Wait a few seconds for the phone to fully power down.
- Boot the iPhone back up by pressing and holding the Power button.
- Reinstall the Vector Robot app from the Apple App Store
- Open the app, log back in (make sure you log into the account your Vector is registered to!) and retry the connection.
- Android Instructions:
- Make sure you are logged in to the correct account.
- In the Vector Robot app, use the Gear icon at the top right to enter the Preferences Menu.
- Scroll all the way down, and click "Disconnect", then click "Log Out".
- Log back in, ensuring that you are logging into the account that your Vector robot is registered to.
- Clear User Data on the robot:
- As a last resort, you may need to do a Clear User Data reset. To clear the User Data on the robot, please see this article:
Performing A Clear User Data Reset
- As a last resort, you may need to do a Clear User Data reset. To clear the User Data on the robot, please see this article: