Vector App Can't Find Vector via Bluetooth
When you receive the error "Vector App Can't Find Vector via Bluetooth," this is usually an easy fix with a few common root causes. Let's explore some ways to resolve this in just a few seconds!
Causes:
- Vector is not in Pairing Mode
- Bluetooth is not enabled on the mobile device
- The Vector Robot app does not have access to Bluetooth permissions
Resolutions:
- Make sure Vector is in Pairing Mode:
- Place Vector on his Charger (Note: The Charger must be plugged in and powered according to these requirements.)
- Double tap his Back Button (This button is on Vector's LED strip on his back. The button will make an audible click when pressed correctly.)
- An icon of a key with 6 pound signs ("######") will appear on his screen.
- Click "Reconnect."
- When the PIN appears on Vector's screen, enter it into the app to continue with setup.
- Enable Bluetooth on the mobile device:
- Follow the steps in Enabling Bluetooth On Your Device
- Click "Reconnect."
- When the PIN appears on Vector's screen, enter it into the app to continue with setup.
- Make sure the Vector Robot app has permissions to access Bluetooth on your device:
- Instructions for iPhone:
- Scroll through your Home screens to find the "Settings" app, then click on it to enter the Settings menu for your device.
- Scroll all the way to the bottom of the Settings menu, and find the "Vector Robot" app. Click on it to enter the app's Settings submenu.
- Under "Allow Vector Robot to Access", make sure that the "Bluetooth" and "Local Network" sliders are positioned to the right and that they appear green. If they are turned off, turn them on.
- Retry the connection to Vector.
- Instructions for Android:
- Find the Settings app (this will vary by software setup and phone manufacturer):
- If you have an App Drawer:
- Locate the App Drawer button at the bottom of the screen.
- Click the App Drawer icon.
- Rotate through App Drawer screens until you find the Settings app.
- Click the Settings icon to enter the Settings app.
- If you do not have an App Drawer:
- Rotate through your Home screens to find the Settings icon.
- Click on the Settings icon to enter the Settings menu.
- If you have an App Drawer:
- Locate the "Apps" menu and enable permissions for the Vector Robot app:
- Scroll down in the Settings menu until you find "Apps." Click to enter the Apps menu.
- Scroll down until you find "Vector Robot", or enter "Vector Robot" into the search if you have a search function in this menu.
- Click on the "Vector Robot" entry.
- Click "Permissions."
- Click on each entry under the "Not Allowed" section and enable any permissions that were not allowed at install.
- Note: We use "Location" to run Wi-Fi scans as required by the Android permissions system. We do not collect a precise GPS location from the device for any reason.
- Note: We use "Files and Media" to export photos from Vector's camera and save them to your device.
- Find the Settings app (this will vary by software setup and phone manufacturer):
- Instructions for iPhone: